Customer Support: 1.866.933.9800

Sales Questions: 1.866.469.6120

Upgrading to Joomla 3.0

J25-banner

Keeping your Content Management System (CMS) up-to-date is essential in maintaining a secure site. As time goes on, exploits and security holes are discovered which can put your website at risk. In general, each major revision of Joomla has a 4-year support cycle before becoming obsolete. Upgrading your site not only improves security, but can potentially boost loading speeds, make the site more user friendly, and provide a better overall experience for visitors.

How do I start the upgrade process?
Before upgrading to a newer version of Joomla, it is important to make sure your current version is updated. This will ensure that problems moving to a brand new version are minimal. It is also a good idea to ensure you have backed up your site in case something goes awry, which can happen.

Even if your version of Joomla is up-to-date, migrating to version 3.0 can still pose some difficulty. You might want to consider using the Akeeba’s JUpgrade or SP Upgrade extension to aid you in the process of migrating, as they will largely streamline the process. These extensions will automatically convert your current databases to those compatible with Joomla 3.0. It is also very important to ensure you have the correct version of PHP on the server, as Joomla 3.0 require PHP 5.3 and higher.

Is there an automatic upgrade option?
In certain versions of Joomla , there is a built in ‘update’ function. You can find this in Administration -> Extensions -> Extensions Manager. Once there, click on ‘Update’, then on ‘Find Updates’. If a new version is found, you will simply have to click on ‘Update’. If you are upgrading from Joomla 1.5, the automatic update feature is not available so you can either utilize a component for the upgrade or have the website recreated in the latest version of Joomla, which can sometimes save time and money.

Will my components and plugins work with Joomla 3.0?
Please be aware that not all extensions are compatible with the latest version of Joomla. Before upgrading, check to ensure there is an updated version or a replacement for any components or plugins your site needs to run. If you are still using Joomla 1.x, there are no updates for your current components and plugins, replacement may be your only option. Since Joomla 3.0 is still relatively new, you may want to upgrade to 2.5 until more plugins are supported.

Keeping Joomla updated is vital to protecting both you and your site visitors. It will ensure that your site is kept up-to-date with the latest security patches and feature enhancements.